1 2 3 Previous Next 30 Replies Latest reply on Feb 20, 2009 6:26 PM by anixh

    VMware Player 2.5 118166 x86_64 Linux RPM missing vmware-config.pl after install

    dzeman Lurker

       

      There is no vmware-config.pl found after installing via RPM to reconfig vmware after a new kernel is installed. Only way to reconfigure is to uninstall the RPM then reinstall. Is there another script that can be run, or is the vmware-config.pl file just missing? The PDF manual for 2.5 references vmware-config.pl... Thanks

       

       

       

       

       

       

       

       

       

       

       

        • 1. Re: VMware Player 2.5 118166 x86_64 Linux RPM missing vmware-config.pl after install
          Hot Shot

          It should build/install the modules when you try to start up if they're not available.  If that doesn't work for whatever reason you can try running vmware-modconfig --console --install-all.

           

          -jay

          • 2. Re: VMware Player 2.5 118166 x86_64 Linux RPM missing vmware-config.pl after install
            dzeman Lurker

            thanks for the reply. vmware-modconfig does the trick for manually compiling new modules. It is not rebuilding and installing automatically on boot however. Using CentOS 5.2 x86_64. Is vmware-config.pl being phased out then?

            • 3. Re: VMware Player 2.5 118166 x86_64 Linux RPM missing vmware-config.pl after install
              Elguapaul Lurker

               

              I apologize for intruding into this thread, however, I too was looking for the config.pl.  I would like to change the network mappings (vmnet0 -> ethX and such).  Is there a tool I could use to do this? 

               

               

              Again... sorry for intruding.

               

               

              • 4. Re: VMware Player 2.5 118166 x86_64 Linux RPM missing vmware-config.pl after install
                guyg61 Novice

                 

                Ditto....   Recently installed the latest VMware Player 2.5 on a Linux Host and cannot find the vmware-config.pl. The documentation makes reference to it. Is there another tool available that takes its place? Or is is just missing?

                 

                 

                 

                 

                 

                Guy G

                 

                 

                 

                 

                 

                 

                 

                 

                • 5. Re: VMware Player 2.5 118166 x86_64 Linux RPM missing vmware-config.pl after install
                  CDH.COM-jasonc-at Novice

                  I ran into this when I tried to install a 32-bit RPM on a 64-bit OS.  Installing from the bash prompt  'rpm -Uhv VMware-Player...rpm' showed me the error I needed to see...

                  • 6. Re: VMware Player 2.5 118166 x86_64 Linux RPM missing vmware-config.pl after install
                    Raydude Novice

                    For vmplayer 2.5 you can do this:

                     

                    vmware-networks --migrate-network-settings /your_path/your.vmx

                     

                     

                    This will import your settings from your vmx.

                     

                     

                     

                     

                    Raydude

                    • 7. Re: VMware Player 2.5 118166 x86_64 Linux RPM missing vmware-config.pl after install
                      tinti1234 Lurker

                       

                      Have the same problem, re-compiling of the module works the way described in this thread, but changing the IP address isn't working this way.

                       

                       

                      Does somebody knows how I can change the IP address for vmnet8?

                       

                       

                      • 8. Re: VMware Player 2.5 118166 x86_64 Linux RPM missing vmware-config.pl after install
                        johnb128 Lurker

                         

                        I'm also missing vmware-config.pl. I'm trying to disable bridging and was able to do that in previous versions with vmware-config.pl.

                         

                         

                        Is there a new way to configure the network?

                         

                         

                         

                         

                         

                        • 9. Re: VMware Player 2.5 118166 x86_64 Linux RPM missing vmware-config.pl after install
                          ritchiev Lurker

                           

                          I am having difficulties, as in earlier version I could change the config through vmware-config.pl (Ubuntu 8.04 host, LTSP), the eth0 is the internal for the LTSP, eth1 for the external (www etc). Now I cannot change the eth0 to eth1 for bridging, and if I change the config file manually then the problem is not fixed some how. Does anybode can give me a hand of how to to it.

                           

                           

                          Thanks, Richard

                           

                           

                           

                           

                           

                          • 10. Re: VMware Player 2.5 118166 x86_64 Linux RPM missing vmware-config.pl after install
                            grantstreet Lurker

                             

                            I have seen this when you try to install the RPM when /dev/tty is not availible. eg install the RPM from rc.local. The way the installer works is that it unpackages an executable into a temp directory and executes it reading from /dev/tty. It is this executable that installs all the files, you can see this by running rpm -ql --scripts VMware-Player . If this command fails for any reason the vmware files will not exist but the OS will think that the RPM is installed. This could explain your symptoms or at least you will know why your symptoms have occured. I have another thread about this with no response.

                             

                             

                            http://communities.vmware.com/message/1101419

                             

                             

                            • 11. Re: VMware Player 2.5 118166 x86_64 Linux RPM missing vmware-config.pl after install
                              mheslep Lurker

                              Well after installing the rpm, and then again trying with just the bundle on 2.5.1, none of the vmxxx modules are installed and /etc/init.d/vmware fails to start.  So the configuration done at install time failed to do what it needed to do.  Then 'vmware-modconfig --console --install-all'   gives a segfault. Arg!!  There's no mention of removal of the long used vmware-config.pl (perl) based tool in the release notes, nor the major switch over to python. ????

                               

                              Fedora 10

                               

                              Linux  2.6.27.7-134.fc10.x86_64 #1 SMP Mon Dec 1 22:21:35 EST 2008 x86_64 x86_64 x86_64 GNU/Linux

                               

                               

                               

                               

                               

                              1. vmplayer

                              Logging to /tmp/vmware-root/setup-18572.log

                              modinfo: could not find module vmmon

                              modinfo: could not find module vmnet

                              modinfo: could not find module vmblock

                              modinfo: could not find module vmci

                              modinfo: could not find module vsock

                              modinfo: could not find module vmmon

                              modinfo: could not find module vmnet

                              modinfo: could not find module vmblock

                              modinfo: could not find module vmci

                              modinfo: could not find module vsock

                              • 12. Re: VMware Player 2.5 118166 x86_64 Linux RPM missing vmware-config.pl after install
                                mwichmann Novice

                                 

                                I guess the subject line isn't helpful any more; it's not the end of the world that the command we're used to doesn't exist any more, but it is a big problem that the replacement segfaults - and there doesn't seem to be a sane way to debug it.   It's failing for me, too - I've tried the 64bit rpm (more on that later) and the bundle, both, and they appear to work fine but the modules aren't found.  When running the command indicated here, it just fails:

                                 

                                 

                                1. vmware-modconfig --console --install-all

                                Segmentation fault

                                 

                                 

                                Again, Fedora 10 x64 version is the host. 

                                 

                                 

                                On the rpm, if you're listening VMware, the new scheme is horrid, please don't do this.  The purpose of using the package manager is to be able to track the files installed, be able to verify them, etc.  If this is not the result of installing a package through the package manager, it's not worth doing at all. This scheme installs the bundle in a temporary location, then the postinstall script runs the bundle and then removes it! This means that the only file actually installed by the rpm does not exist on the system after the installation is complete; meanwhile the whole set of files actually installed is nowhere tracked by the package manager.  If you're going to do things this way...well... just forget about distributing an rpm and tell people to use the bundle, there's no difference except with the bundle people at least won't have an apparent broken package should they run "rpm --verify".  This is bad enough that when distros start doing 3rd-party whitelist/blacklist settings (probably something that will become prevalent quite soon), I can pretty much guarantee vmware player and anything else that uses this scheme will end up being blacklisted.

                                 

                                 

                                 

                                 

                                 

                                • 13. Re: VMware Player 2.5 118166 x86_64 Linux RPM missing vmware-config.pl after install
                                  Speedbird Novice

                                  Hi there,

                                   

                                  I am having the same issue (installing either the RPM or the .bundle versions) (My System is a Fedora 10, Kernel Version 2.6.27.9-159.fc10.x86_64). I believe there are two main problem here: (1) that the installation itself fails and also fails to report that back to the user, and (2) the reason that it fails is that it cannot compile a kernel module, here is a snippet from /var/log/vmware-installer:

                                   

                                  Configuring Bridged network vmnet0 Configuring hostonly network vmnet1, probing for unused subnet ... Configuring NAT network vmnet8, probing for unused subnet ... Configured default networks - Bridged, Hostonly, NAT Stopping cups: \[ OK \] Starting cups: \[  OK  \] Unable to install kernel modules Using UI type null Opening database file /etc/vmware/database Stopping VMware services: Virtual machine communication interface\[  OK  \] Virtual machine monitor\[  OK  \] Blocking file system\[  OK  \]

                                   

                                  And then in the same log file I see a command line usage dump from gconftool-2 which tells me that the installer script probably tried to execute it with invalid/obsolete parameters

                                   

                                  I am actually surprised that just a few people have reported this issue, I just hope this does not mean that FC users are declining

                                   

                                  And finally, I believe the ulprit is the installation of /usr/lib/vmware/modules/source/vmmon.tar which is added bythe installer, it is failing trying to compile some header files that are not located in the approprtiate directories in the kernel source (local) tree (asm and linus folders specifically), there could be more issues like this one though, I hope this helps a bit.

                                   

                                  Thanks,

                                   

                                  SB

                                  • 14. Re: VMware Player 2.5 118166 x86_64 Linux RPM missing vmware-config.pl after install
                                    RonnieD Lurker

                                     

                                    Hi there,

                                     

                                     

                                     

                                     

                                     

                                    after browsing the net i found the following solution.

                                     

                                     

                                    -


                                     

                                     

                                    The vmware-config.pl script has been incorporated into the

                                    installation routine so you can’t issue it via command line anymore,

                                    but VmWare won’t remove this without replacing it with something else

                                    (they’re not Microsoft :P) so you can issue the following command to

                                    force the reconfiguration and  reinstallation of kernel modules :

                                     

                                     

                                    +vmware-modconfig –console –install-all +

                                     

                                     

                                    This will make the actual seg-fault error show up now simply issue :

                                     

                                     

                                    mv /usr/lib/vmware/modules/binary /usr/lib/vmware/modules/binary.old (or whatever name you prefer, this is just to rename the binary directory to something else).

                                     

                                     

                                    Now everything should be fixed and you can issue again :

                                     

                                     

                                    +vmware-modconfig –console –install-all +

                                     

                                     

                                    -


                                     

                                     

                                    It worked for me on opensuse 11.1 and vmplayer 2.5.1

                                     

                                     

                                    Not sure if these files where there before installation and made it fail or these files are placed there by the installer.

                                     

                                     

                                    Have fun!

                                     

                                     

                                    1 2 3 Previous Next