9 Replies Latest reply on Sep 9, 2010 2:29 AM by Vetal981

    Invisible Mouse Cursor on Text Editors (Vista Host)

    schmirck Novice

       

      Hi,

       

       

      I installed VMWare Player 2.0.1 on my Windows Vista. I'm running Windows XP Pro as the guest OS (setup/version details at the end of this mail).

       

       

      The problem is that in the guest OS (WinXP), the mouse pointer becomes invisible whenever it hovers over a text editing control (notepad, textbox, Visual Studio 2005 IDE, etc). It still works though, I just have to guess where the mouse is pointing. Is there a setting that I need to add or configure?

       

       

      Currently, my work-around is to access the guest OS through Remote Desktop Connection.

       

       

      Thanks for any help!

       

       

      SETUP DETAILS

       

       

      VMware® Player

      Version: 2.0.1 build-55017

       

       

      Host:

        OS - Microsoft Windows Vista Home Premium 6.0.6000  (32 bit) - factory default

        Hardware (Presario V3525):

          - Core 2 Duo 1.66GHZ  1.67GHZ

          - 2036 MB RAM

          - Video: Mobile Intel(R) 965 Express Chipset Family (173 MB)

       

       

      Guest:

        OS - Windows XP Professional SP2  (32 bit)

        RAM - 896 MB

        WMWare Tools installed: Build 56528

       

       

       

       

       

        • 1. Re: Invisible Mouse Cursor on Text Editors (Vista Host)
          tetset Novice

          I have this too, with Windows XP Pro as host. Using the 'Windows Black System Scheme' in 'Mouse Properties' is a work around.

           

          I don't recall this with 2.0.0, so it looks like a newly added 'feature'.

          • 2. Re: Invisible Mouse Cursor on Text Editors (Vista Host)
            tetset Novice

            A better work around:

             

            right click desktop

            select settings tap

            click advanced

             

            select troubleshoot tab

            drag hardware acceleration slider one click to the left (disable cursor accelerations)

            click OK

             

            click OK

            1 person found this helpful
            • 3. Re: Invisible Mouse Cursor on Text Editors (Vista Host)
              enerata Novice

              Thank you, that really did the trick

              • 4. Re: Invisible Mouse Cursor on Text Editors (Vista Host)
                enerata Novice

                 

                Hi again,

                 

                 

                This procedure causes performance decrease. I have Full Acceleration instead of No Acceleration.

                 

                 

                • 5. Re: Invisible Mouse Cursor on Text Editors (Vista Host)
                  schmirck Novice

                   

                  yup... Changing acceleration settings may give you problems... and i'm kinda doing some software development, changing some system settings may affect performance of the applications that i'm creating... that's why I'm sticking with changing the pointer scheme in the mouse properties.. thanks for this tip tetset..

                   

                   

                  Cheers!

                   

                   

                  <btw, why cant this editor open in Vista??? i had to post my replies in my office PC which runs on XP... :-(>

                   

                   

                  • 6. Re: Invisible Mouse Cursor on Text Editors (Vista Host)
                    enerata Novice

                     

                    I'm writting message from Vista/Firefox 2. Although I have NoScript javascript is enabled for this site. Most probably, if you're using IE, you are not allowed to run any javascript due to the security constrains IE7 applies.

                     

                     

                    Just to express my opinion though, I don't find an editor usefull, but rather annoying

                     

                     

                    • 7. Re: Invisible Mouse Cursor on Text Editors (Vista Host)
                      dbaps Novice

                       

                      Bought a laptop a few weeks ago.  Running Vista as my host and XP Pro as my Guest.  This is the only solution I've found, even on 6.5, that fixes my mouse problem.  I have one mouse I can see that is not the Guest mouse, and a second that is invisible that of course I can't see.  Redusing the acceleration one notch fixes this problem.  Even turning the mouse color to black does not work for me.

                       

                       

                       

                       

                       

                       

                       

                       

                      • 8. Re: Invisible Mouse Cursor on Text Editors (Vista Host)
                        OzoZoz Lurker

                        I had the same problem, i.e. the "Text Select" cursor was invisible in my XP guest OS. For some reason, it seems the default Text Select cursor is too thin to show on my laptop screen (it shows well on my desktop running the same XP guest though). Anyway, the solution is to replace this pointer graphical representation with some other cursor shape that's slightly larger.

                         

                        So in my case, I saved a copy of the "Windows Default (system scheme)" into a new "My Default Scheme", and then I edited the "Text Select" pointer of my new scheme to use the "beam_r.cur" cursor representation (which seems to be slightly thicker than the default one). It worked for me. You can access these mouse pointer schemes through the "Pointers" tab of the "Mouse Properties" of your XP guest OS.

                         

                        Ozo.

                         

                        \[Edit by OzoZoz\]: FYI, ... I realized that MS Word also has many different "Select Text" icons that are slight variations derived from the default Windows one; And they all disappear the same way (they are all as thin as the original Windows one). That means I would need to change all these icons as well if I want MS Word (and the Word-enabled MS Outlook editor) to never suffer from cursor invisibility, ... and I don't know how to changes these MS Word specific mouse cursor shapes (I am still looking). So I looked at disabling cursor h/w accelleration (like others suggested in this thread). It surely resolves the issue with the cursor invisibility, but it creates (on my system) a new problem: the Host and Guest OSs don't have their cursor perfectly aligned anymore, which results in an impossibility to use the top toolbar of the VM Player when my VM is maximized. Very annoying.

                        • 9. Re: Invisible Mouse Cursor on Text Editors (Vista Host)
                          Vetal981 Lurker

                          Also you can try to choose Windows Black system scheme in mouse pointers, because when you turn off hardware acceleration mouse cursor will be moving with big delays. Now it works for me)