1 Reply Latest reply on Aug 17, 2008 4:09 AM by bcsapman

    disable memory trimming impossible in RC1?

    bcsapman Lurker

       

      :)I tried to disable the memory trimming. I think this is per default activated in this product for all guests.

      (memory trimming := release allocated Memory from Guest and give it back to use with other VMs on Host)

       

       

       

      The Taskmanager on host displays after starting the guest alwas the allocated 7GB RAM.

      This matches with the VM GUI. This is steady as aspected.

       

       

       

       

       

      Guest is Win2003EE 64bit running SAP NW04s. VMTools are installed.

      Taskmanager of Guest shows total mem 5,1GB and avail 1,2GB.

      VM GUI shows: configured Memory 6100MB but Used only:793MB

       

       

       

      Directly after starting the Application in the VM, the used memory tops the 5GB and looks as configured.

      But: after a few minutes the used memory decreased steady and stays below 1GB (and swaps all other pages).

       

       

      Can't VMware Server handle Memory-eating application correctly?

       

       

      Or is this a simle configuration mistake? (please point me to the correct way )

       

       

       

      Thanks in advice,

      bcsapman

       

       

       

      Attached, my configs - using Windows XP 64 as Host system with following config.ini:

       

      prefvmx.allVMMemoryLimit = "7371"
      prefvmx.minVmMemPct = "100"
      prefvmx.useRecommendedLockedMemSize = "TRUE"
      sched.mem.pshare.enable = "FALSE"
      mainMem.partialLazySave = "FALSE"
      mainMem.partialLazyRestore = "FALSE"
      mainMem.useNamedFile = "FALSE"
      MemAllowAutoScaleDown = "FALSE"
      MemTrimRate = "0"

      the one and only Guest .vmx settings (partly) using Windows 2003 EE Server 64bit:

       

      memsize = "6100"
      mainMem.partialLazyRestore = "FALSE"
      mainMem.partialLazySave = "FALSE"
      mainMem.useNamedFile = "FALSE"
      prefvmx.minVmMemPct = "100"
      prefvmx.useRecommendedLockedMemSize = "TRUE"
      sched.mem.pshare.enable = "FALSE"
      MemAllowAutoScaleDown = "FALSE"
      MemTrimRate = "0"