VMotion problem - 'device with remote backing' - Greyed out CD-ROM - no vmotion

Version 2

    When trying to VMotion from one ESX server to another, I receive this error:

    Unable to migrate from ESX1 to ESX2: Virtual machine is configured to  use a device that prevents migration: Device 'CD/DVD Drive 1' is a  connected device with a remote backing.

    If i view the virtual machine properties, the CD/DVD drive is showing as  'Connected - client unknown'. All of the CD/DVD properties are greyed  out.

    I can click the 'Disconnect D:' button on the toolbar with the VI client, but this doesnt have any effect.

    Any ideas?!

    P.S i even tried removing the CD/DVD device whilst the VM was powered  off, powering up the VM, powering it down, and re adding the CD/DVD but  this didnt have any effect.

    Thanks

     


    You should find what is configured to use the device.
    Another way: did you try unistalling the device in the virtual OS?

     


    I have this same issuse on a VM i use for testing VMotion, its been used 100's of times for VMotion..

    Removing the CD/DVD didnt help, but removing both the CD/DVD and Floppy did the trick..

    I havent looked too deeply into it.. But will do later..

     


    I think that is caused by a vcenter user with the console open to the VM  that has the CD connected via Device type "Client Device"

    Check the sessions on the server and see if anyone has that vm open.

     


    I added my CD/DVD and floppy back, but still get the issues.. But that a  good shout, as that VM has had console connected via VC, although all  have been closed and VM rebooted etc..

     


    That's really curious.  If you can shutdown the vm for a few minutes,  try making a new VM pointing to the existing disk files and see if that  will vmotion.

     


    Im quite sure that would work, i'll see if i can get chance to test..

     


    Couldn't work out what was causing this...there weren't any sessions showing.
    I removed the VM from virtual center, and then re-registered it. This did the trick - can now VMotion OK.

    thanks for the suggestions.

     


    Glad to hear that helped.

    Thanks for the points!

     


    I'm still having these problems, but now it's happening on 9 of our VMs -  a real pain. Only way I can see to fix is to remove the VMs from  virtual centre and reregister them.

    Just wondering if anyone else has any ideas?

    James

    Message was edited by:
    jparnell

     


    I've had the same problems on my VMs running linux OS-es.
    And NOW I resolve the problems!! Yeah!!

    The cause is that my VMs hold "VMware Tools Install" images on their Virtual CD-ROM drives.

    Click "Inventry->Virtual Machine->End VMware Tools Install".
    It may save you.

     


    I have seen this too.  If the VM tools install thinks it is still  running the CD drive is mapped to the iso file on the host.  You wont be  able to VMotion until you disable the tools install.

     


    I had the same problem and found this solution in another post:

    When trying to vmotion a virtual machine you may get an error message  that says you cannot migrate the vm because the CD is connected to a  device that prevents migration.  If you try to disconnect that device it  may stay connected.  If it does, open an SSH connection to the ESX  host.

    Once connected run the following command:  "service mgmt-vmware restart"

    This will restart the management interface and should clear the connection to the CD or floppy.

    Bill S.

     


    I couldn't select to end my instlal but doing a "repair" fixed my remote backing issue.

    Ben

     


    I have tried th uninstall and re-install of both the floppy and the  CD-Rom although still no luck. What I did find to work more than once it  powering down your VM > ensure either Floppy and or CD-Rom are both  disconnected > Migrate to another ESX server > Power VM up >  try to VMotion.

    I hope this helps

    JC

     


    Had another one today, I did a 'mgmt-vmware restart' and it fixed the problem.

     


    This should cure the problem without the need to shutdown the VM...

    Select "Install VMware Tools" on the Virtual Machine - this will initiate the VMware Tools Installer Mount.

    Select "End VMware Tools Install" - this will unmount the Tools Installer.

    A word of warning, the VMware Tools Installer Mount will forcibly  disconnect the remote device, so if someone has genuinely mounted a  Virtual CRDOM it will be lost.

     


    Hi,

    I got a similar message during VMOTION. To resolve the issue, i did the following.

    1. Rihgtclick on the Virtual Machine and select 'Edit Settings'
    2. Select (Highlight) CD/DVD Drive 1
    3. On the right hand side under Device status, uncheck the box 'Connected'
    4. Try VMOTION (drag and drop the Virtual machine) and it should work.
    5. If required then check the box which was unchecked in step 3 (for the moved VM on the target server).

    Hope this helps!

    Regards,
    Ronald

     


    In this scenario the CD/DVD Device Status shows up as "Connected -  client unknown" and all of the properties are greyed out, so you can't  Edit the Settings.

    I am not absolutely certain what the reason is for this behaviour, but I am able to recreate it...

    Connect a CD to a VM, then shutdown & power off; now remove the CD  (i.e. set to "Client Device"), then power back on.  Now try to VMotion  and Hey Presto "Device 'CD/DVD Drive 1' is a connected device with a  remote backing" and all options greyed out.

    The only certain workaround that I have found for this is to "Install  VMware Tools"/"End VMware Tools Install", or even better disconnect the  CD before shutting down the VM!

     


    I've recently migrated a load of servers using vmware converter - and I  have noticed we recieve the error on every server we migrate. I have got  into the habbit of "install vmware tools"/"end vmware tools install"

     


    One more addition. The previously posted solutions did not work for me  but i found that my guests CDROM was configured to "Emulate IDE" under  the Mode section  in properties of the CDROM. I set it back to  Passthough IDE and vmotion worked with properly.
    DG

     


    Had this problem with one machine this morning.

    To fix it, I had to remove the cdrom AND floppy disk -> bootup so  windows removed them from dev mgr -> shutdown and re-add them.  (For  good measure, you may consider deleting the hidden devices.)

    FWIW, the cd rom was originally set for "Emulate."  Changing it to Passthrough did not work for me.  I had to remove both devices.

     


    I went into device manager and disabled the floppy drive and cd-rom.   Once I did this I clicked edit settings and the cd-rom was no longer  connected and I could migrate.

     


    I simply reinstalled my VMWare Tools and it enabled me to VMotion correctly.

    Thanks,


    Josh

     


    I had this issue on all my VMs since I had installed VMtools.  I did a  service mgmt-vmware restart on each ESX host 1 min later connected to  unknown  with the check box was gone...works like a charm.

    This document was generated from the following thread: VMotion problem - 'device with remote backing'