there have always been issues with vmware and  red hat rhel vm guest rtc clock & time syncronisation and its still true in 2010 ! this is in part due to the kernel clock defaulting to 1000Hz in the centos, oel, red hat rhel enterprise 4 or 5 gnu/linux distros

 

you can check what speed your kernel is currently running at by running

 

$ watch -d cat /proc/interrupts

 

and watch by how much the "0:" and "LOC:" counters increment each second ! if they are incrementing by 2000 then your kernel clock is running at 1000Hz if by 200 then your kernel clock is running at 100Hz !

 

you can reduce the kernel clock rate in later versions of rhel 4 & 5 by adding divider=10 into the kernel start  parameter line in your /boot/grub/menu.lst

 

for more info and other kernel start params such as clock= and clocksource= see

 

http://blogs.vmware.com/management/2010/06/updated-timekeeping-in-vmware-virtual-machines-paper-available.html

http://www.vmware.com/vmtn/resources/238

http://www.vmware.com/resources/techresources/238

http://www.vmware.com/files/pdf/Timekeeping-In-VirtualMachines.pdf

http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1006427

 

so if you are running 10 rhel vms on your vmware server and switch from 1000Hz kernels to 100Hz kernels you can reduce the total number of interrupts vmware has to virtualise for all the vms from 10000 to 1000 per second !